Jagged Alliance Center - Forum

Nowy temat Odpowiedz w temacie  [ Posty: 28 ]  Przejdź na stronę   Poprzednia   1, 2
Autor Wiadomość
M'cin
Post : 03 wrz 2010 20:46
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Starszy chorąży sztabowy
Starszy chorąży sztabowy
  • Posty: 753
  • Dołączył: 18.11.2009


Szczerze, to nawet nie wiem, co to jest :D\

Wracając do BS'a, efekty widać na screenie... Dziś już nie mam siły, jutro z płytki spróbuję walnąć 7.62, może pomoże... a jak nie, to podrzucisz linki od tego R@Sa czy jak mu tam, jak możesz, te Lukasowwe mogą być trefne.

Aha i uwaga do updatera - zapamiętuje on gdzie ostatnio wskazałem podane pliki, ale nie media packi i muszę je za każdym razem dodawać... kilka sekund, ale tyle razy to robiłem, że staje się upierdliwe


Załączniki:
bsss.JPG
bsss.JPG [ 66.92 KiB | Przeglądany 568 razy ]
*
 
aszek
Post : 03 wrz 2010 21:10
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Sierżant
Sierżant
  • Posty: 260
  • Dołączył: 13.11.2009


No przecież szło, po cholerę klikałeś 'przerwij' ? Ten przycisk służy do opdalenia/przerwania i wyjścia z aplikacji (w zależności od fazy). Po prost czekaj aż będzie pisało, że aktualizacja się zakończyła.

_________________
Obrazek kogo by tu jeszcze sprać, no kogo... ? - Wojmił (brat księcia Mirmiła)


*
 
M'cin
Post : 04 wrz 2010 14:30
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Starszy chorąży sztabowy
Starszy chorąży sztabowy
  • Posty: 753
  • Dołączył: 18.11.2009


No właśnie ani razu nie kliknąłem przerwij i na tym polega problem!

No cóż... spróbowałem wypakować wszystko ręcznie według Twych rad z 13 lipca i późniejszych (kolejność: media packi, patch, bat i mod) i wszystko śmiga aż za dobrze, gra się uruchomiła, włączyła i działa. Więc albo updater źle napisany, albo coś nie tak z paczkami, albo brak kompatybilności z moim Phenomem X3 8750 i XP SP3, aktualizowane wszystko około miecha temu.


Ostatnio zmieniony 04 wrz 2010 14:58 przez M'cin, łącznie zmieniany 1 raz

*
 
aszek
Post : 04 wrz 2010 17:00
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Sierżant
Sierżant
  • Posty: 260
  • Dołączył: 13.11.2009


No to nie mam pojęcia dlaczego u Ciebie updater nie działa, ale byłbym ciekaw czy to odosobniony przypadek, więc jeśli ktoś jeszcze miał problem to proszę o info. Może gdzieś spieprzyłem kod, choć w tym momencie nie mam pojęcia o co może chodzić.

U siebie gram w E6 skonsolidowanego przez updatera i testowałem wielokrotnie jego działanie - na procku z dwoma rdzeniami, chyba że... może chodzi o te 3 rdzenie AMD i ustawienie koligacji by pomogło ?

Sorki że updater u Ciebie nie działa.

_________________
Obrazek kogo by tu jeszcze sprać, no kogo... ? - Wojmił (brat księcia Mirmiła)


*
 
M'cin
Post : 05 wrz 2010 10:40
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Starszy chorąży sztabowy
Starszy chorąży sztabowy
  • Posty: 753
  • Dołączył: 18.11.2009


A jeszcze jeden pomysł mam, może to ja schrzaniłem... Nie updatowałem 7.62 czystego, z płyty, tylko wersję, w którą grałem jakiś czas temu, jeszcze przed formatem. Jeżeli to musi być nieruszana wersja, świeżo po instalce, to... no, to wiadomo ;)


*
 
aszek
Post : 05 wrz 2010 11:15
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Sierżant
Sierżant
  • Posty: 260
  • Dołączył: 13.11.2009


No świeża, zaraz po instalce. Pisałem o tym kilkukrotnie (updater też o tym wspomina), ale nie przejmuj się, bo przy okazji wyszło że patch na JAC siedzi w podfolderze.

Czy mógłbym prosić moderację o przesunicie postów dt. updatera do:
http://forum.jagged-alliance.pl/narzedzia-do-modowania-7-62-t1949.html
bo tu rozjechały się z tytułowym BSem.

_________________
Obrazek kogo by tu jeszcze sprać, no kogo... ? - Wojmił (brat księcia Mirmiła)


*
 
M'cin
Post : 06 wrz 2010 10:32
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Starszy chorąży sztabowy
Starszy chorąży sztabowy
  • Posty: 753
  • Dołączył: 18.11.2009


A to sorki, trochę czasu niepotrzebnie Ci zabrałem :P


*
 
Lutek70
Post : 15 wrz 2010 11:19
Cytowanie selektywne Odpowiedz z cytatem
Kapral
Kapral
  • Posty: 54
  • Dołączył: 29.07.2010


Użyłem Twojego programu wg zaleceń i ciągle wyskakuje okno żądające jakiegoś pliku "volume",wszystkie pliki ściągnięte z JAC


*
 
aszek
Post : 15 wrz 2010 11:39
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Sierżant
Sierżant
  • Posty: 260
  • Dołączył: 13.11.2009


Pobierz tego patcha:
http://www.aszeq.republika.pl/762/Unofficial%20Patch%201.06.7z

albo wypakuj tego co już masz i wskaż updaterowi plik 'Unofficial Patch.txt'.

.7z jest w kilku wersjach (algorytm pakowania). Biblioteka .dll którą użyłem (wersja 4.65) nie zna tej wersji archiwum które jest wrzucona w downloadzie na JAC (tam jest jakaś późniejsza wersja) dlatego się rzuca o następny part (volume). Przy okazji (z następnym BS'em) to poprawię.

_________________
Obrazek kogo by tu jeszcze sprać, no kogo... ? - Wojmił (brat księcia Mirmiła)


*
 
lukasamd
Post : 15 wrz 2010 12:38
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Pułkownik
Pułkownik
  • Posty: 5313
  • Dołączył: 31.05.2006


No to ja dla jasności tylko napisze, że do downloadu trafiają pliki pakowane najnowszą wersją 7-zipa, te z patcha były pakowane 9.15 beta.


*
  WWW
Lutek70
Post : 15 wrz 2010 13:32
Cytowanie selektywne Odpowiedz z cytatem
Kapral
Kapral
  • Posty: 54
  • Dołączył: 29.07.2010


POSZŁO! :D Wszystko hula aż miło!Dzięki Aszek!Wreszcie mogę porezać :diabel2:


*
 
aszek
Post : 19 wrz 2010 06:37
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Sierżant
Sierżant
  • Posty: 260
  • Dołączył: 13.11.2009


Trochę szybsza (~2x) i bardziej rozbudowana wersja aktualizatora, nazwijmy ją 2-gim podejściem do tematu:

http://www.aszeq.republika.pl/762/Aktualizacja_762HC.zip

Obrazek

Jeśli komuś się nie udało przebrnąć przez aktualizację w poprzedniej wersji programu, to teraz się na pewno dowie dlaczego :P

Kompatybilne z poprzednimi odsłonami moda i patcha, czyli na dzień dzisiejszy:
- Unofficial Patch 1.06EN (jako .RAR z serwera mediafire, ew. .7z z linka którego dawałem od siebie)
- The Blue Sun Mod Base 1.3RV (jako .RAR z serwera mediafire, ew. z downloadu na JAC)
- The Blue Sun Mod Media Pack razem z 1.3RV (jako .RAR z serwera mediafire, ew. z downloadu na JAC)

Na razie nie wiem jak będzie z kompatybilnością po wdrożeniu przez R@Sa nowego moda już z TAX Addon (choć updater jest przygotowany na nowy konfig), jak wyjdzie coś nieprzewidzianego to wrzucę dostosowaną wersję aktualizatora.

Wsparcia dla 7zipa w wersji 9.16B nie będzie, bo Rosjanin, autor biblioteki .dll zawiesił pracę nad jej publicznym wykorzystaniem już na wersji 4.42 i pewnie chodzi o monopolizację jego menadżera (tego formatu) - no to ja mówię hasta la vista temu shitowi. Jedynie co mogę obsłużyć to wersję 4.42 (nawiasem mówiąc pakuje lepiej). To tak w kwestii wyjaśnienia dlaczego patch z downloadu na JAC nie działa - no chyba że LukasAMD (o co go pięknie proszę :one: ) dla zgodności wrzuci zamiast obecnego pliku - ten (przepakowane z info o JAC i na dodatek mniejszy):

http://www.aszeq.republika.pl/762/Unofficial%20Patch%201.06.7z


Na przyszłość jest też opcja ze sprawdzaniem aktualizacji przez net. Na webie umieściłem mały pliczek tekstowy z odpowiednią informacją dla softu i o ile się pojawi nowa a i stabilna (Release Version) wersja BS'a to będę go aktualizował. Pliczek jest osiągalny jako http przez port 80 więc to normalna, kliencka transmisja przęglądarkowa i nic tam nie wysyłam (gdyby ktoś pytał :P).


Jeszcze słowo wyjaśnienia o co chodzi z tym konsolidowaniem. Mianowicie, w świeżo zainstalowanej grze panuje (że się tak wyrażę) spory burdel. Dystrybutor nie zadał sobie trudu aby trochę po sobie posprzątać i na dzień dobry mamy niespodziankę po ich crashu (log) oraz uwalonych kilka plików które patch poprawia (ciemności w sklepie), oraz niedoróbki przy tłumaczeniu na EN jak niedziałające granatniki, itp. Na dodatek, to co znajduje się w kolejnych patchach (które dostajemy firmowo) jest powielane w nich samych oraz po raz N-ty w folderach gry - no i gierca dzięki temu nie dość że się długo ładuje to ma też skłonność do niszczenia dalszych plików (brak atrybutu 'tylko do odczytu'). To co nazwałem konsolidacją ma na celu spakować wszystko do jednego pliku, tak aby pliki gry się nie powtarzały i nie mogły być zniszczone. Unofficial Patch również.

Teraz obok gry przychodzi sam mod, który jest potraktowany identycznie. Jeśli ktoś będzie miał kiedykolwiek ochotę pozbyć się moda (wymienić) to zamiast całej reinstalki może usunąć .azp Blue Sun'a oraz poprawić (ręcznie) dwa konfigi (vfs.ini oraz e6q.modinfo) - inaczej nie byłoby wiadomo co właściwie z czego jest. W przypadku wymiany nie trzeba tego nawet robić, bo aktualizator (o ile ręcznie mu nie pomożemy) zrobi to sam nadpisując nową wersją moda.

_________________
Obrazek kogo by tu jeszcze sprać, no kogo... ? - Wojmił (brat księcia Mirmiła)


*
 
lukasamd
Post : 19 wrz 2010 10:37
Cytowanie selektywne Odpowiedz z cytatem
Awatar użytkownika
Pułkownik
Pułkownik
  • Posty: 5313
  • Dołączył: 31.05.2006


aszek pisze:
Wsparcia dla 7zipa w wersji 9.16B nie będzie, bo Rosjanin, autor biblioteki .dll zawiesił pracę nad jej publicznym wykorzystaniem już na wersji 4.42 i pewnie chodzi o monopolizację jego menadżera (tego formatu) - no to ja mówię hasta la vista temu shitowi. Jedynie co mogę obsłużyć to wersję 4.42 (nawiasem mówiąc pakuje lepiej). To tak w kwestii wyjaśnienia dlaczego patch z downloadu na JAC nie działa - no chyba że LukasAMD (o co go pięknie proszę :one: ) dla zgodności wrzuci zamiast obecnego pliku - ten (przepakowane z info o JAC i na dodatek mniejszy):


Patch został zamieniony:
https://jagged-alliance.pl/plik306/

Sprawdzałem i rzeczywiście wersja 4.42 kompresuje lepiej... ciekawe skąd takie różnice - muszę jeszcze potestować na jakichś większych paczkach.

EDIT:
A jednak nie jest tak różowo - na paczkach z wieloma typami plików wyniki są bardzo podobne, lub wygrywa (acz minimalnie) nowsza wersja.
Poza tym obsługuje więcej typów archiwów, więc u mnie na kompie na pewno zostaje 9.16B x64 :P


*
  WWW
Nowy temat Odpowiedz w temacie Przejdź na stronę   Poprzednia   1, 2


cron